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1

SoftClient Operation
1.1

General Description

STENTOFON SoftClient is a software application that functions as an IP
intercom station for connection to the AlphaCom XE Audio Server.
SoftClient will turn your PC into a STENTOFON intercom, providing
access to a wide range of critical communication services. These
services include the ability to make intercom calls, public address calls,
external telephone calls, and to communicate with radios.
Some typical areas for using SoftClient are:
●● Control room applications integrating intercom
●● Reception services handling door calls
●● People on the move requiring access to the AlphaCom XE services
via their laptops
SoftClient supports all features of the STENTOFON AlphaCom XE audio
servers. In addition, it offers enhanced functions that make SoftClient
extremely user-friendly.
When the station is sized, all visible elements within the station scale
proportionally. This allows for easy operation on screens of different sizes
and resolutions, a particularly important feature for operating via a touch
screen. Elements which do not need to be visible do not take up space
on the desktop.
The station allows dialling directly from the PC keyboard in direct mode,
where digits are dialled as they are typed, and in indirect mode, which
allows the number to be edited before it is dialled. The M and C keys
can also be operated from the PC keyboard, which is especially useful
when, for example, the M key needs to be used by radio operators for
transmitting a message.

1.2

Sizing and Placing the SoftClient GUI

The keystrokes Ctrl+- and Ctrl++ can be used to size the SoftClient GUI
to fit the screen as required.
Sizing is also possible via the View menu.
By clicking in an otherwise inactive part of the SoftClient interface, it is
possible to drag it to any place on the desktop.
When SoftClient is closed and then reopened, it will be displayed at the
same location and with the same size prior to it being closed.

1.3

4

Keypad

The keypad corresponds to the STENTOFON IP intercom station keypad
(numeric and M-Key/C-Key) and can be used to dial any directory
number registered in AlphaCom XE. The keypad can be made visible or
be hidden by clicking the keypad icon.
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1.4

Contact List

From the contact list it is possible to select the station/extension to call.
To open or close the contact list, click the contact list icon.
The call can be initiated by double-clicking the contact in the contact list.
The columns in the contact list can be sorted alphabetically or numerically
by clicking the column name.
At the top of the contact list there is an input field. Entering characters in
this input field narrows the number of visible contacts down as the input
string is used as a filter. The filter works on all the columns in the contact
list.

1.5

Calling from the PC Keyboard

There are two ways in which the PC keyboard can be used to dial an
extension:
Direct mode
When the station display has the focus (click the display to choose it), it
is possible to dial using the numeric keypad on the PC keyboard. As the
numbers are pressed, they are entered on the station display and when
all the numbers in the extension have been entered, the connection to the
called party is made automatically and the display color changes to blue.
When SoftClient is first opened, the station display normally has the focus
by default.
Indirect mode
When the input field has the focus (click the field and a cursor appears),
the PC keyboard can be used to enter a directory number or a contact
name in the field. When starting to type, a dropdown list will appear
showing all the known contacts from the contact list. It is then possible to
scroll through this list, or continue to enter additional characters.
Pressing Enter on the PC keyboard or clicking a number/name in the
dropdown list will cause the extension to be dialled. Indirect mode also
allows the user to edit the number before it is dialled.

1.6

1.7

History of Outgoing Calls/Redial

Any outgoing calls with a party which is available in the contact list is
retained by SoftClient for re-dialling. Clicking the Call key will reveal a
list of the most dialled numbers, sorted by call frequency. The first 10
numbers are visible directly. If there are more than 10 dialled numbers in
the cache, a scrollbar will be available.

Cancelling a Call

From SoftClient, a call can be cancelled by clicking the Call-End key, the
C-Key, or Send C-Key under the Actions menu.
From the PC keyboard, it is possible to cancel a call by pressing Ctrl+C,
C, or Delete.
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1.8

Open/Private Selection

Incoming calls are auto-accepted when SoftClient is in Open mode or are
annunciated with a ringing tone when it is in Private mode.
The station can be toggled between these two modes by clicking the
Open/Private keys:
●● When the station is in Open mode, click to change to Private mode.
●● When the station is in Private mode, click to change to Open mode.
The Open/Private selection can also be made from the Actions menu.

1.9

Muting the Microphone

When in a conversation, it is possible to mute the microphone by clicking
the microphone icon. Clicking it when the microphone is muted will
activate the microphone again.
The microphone is always active at the start of a new conversation, even
if it was muted at the end of the preceding connection.

1.10 M-Key Operation

The M-Key is used to accept calls when the station is in private mode, but
also as the Push-To-Talk button during group calls, simplex conferences,
speech direction override or radio communication.
Click the M-Key to operate it. When the display of the SoftClient has
the focus, pressing the M key on the PC keyboard has the same effect.
The M-Key can be kept pressed as long as is necessary for the relevant
action. When the M-Key is used for Push-To-Talk communication, the
microphone will be muted when the M-Key is released, as indicated by
the microphone mute icon. Note that in this case, clicking the mute icon
to activate the microphone again will not have a noticeable effect, as the
speech direction logic of the AlphaCom XE will determine whether the
audio of the microphone will be audible at the remote end.
To accept a call, the M-Key can also be activated by clicking Actions >
Send M-Key or by pressing Ctrl+M. on the PC keyboard.

1.11 SoftClient is Not Visible

SoftClient may not be visible, in which case it is running in the
background. By right-clicking the SoftClient icon in the system tray at the
right-bottom corner of the desktop, it is possible to bring SoftClient to the
foreground by clicking Restore.
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Installation & Configuration
2.1

2.2

Licensing

The SoftClient software is freely available but its use is a licensed feature
in the AlphaCom XE Audio Server. As many SoftClient intercoms can
register simultaneously with AlphaCom as the number of licenses that
have been purchased.

Installing SoftClient

The SoftClient software is developed for PCs running Windows XP or
Windows 7 operating systems.
The software setup file is distributed as SoftClientSetup.msi. Doubleclicking this file will automatically start the setup process. Follow the
instructions in the setup wizard to install the SoftClient software.
The setup process will install the software in the directory C:\Program
Files\STENTOFON\SoftClient by default.
The default installation process will add a Start menu shortcut under
STENTOFON > SoftClient.

2.3

2.4

SoftClient in AlphaNet

When SoftClient is used in a network of AlphaCom XE servers, the
RTP packet size must be set to 20 milliseconds for AlphaNet routing in
AlphaPro.

Connecting to AlphaCom XE

For SoftClient to be able to connect to AlphaCom XE, the following
procedure should be carried out:
1. Select File > Preferences
2. In the AlphaCom IP Address field, enter the IP address of
AlphaCom XE
3. In the field AlphaCom ID, either enter a MAC address or the
directory number which is assigned to SoftClient

-- Note that this MAC address can be any arbitrary value which can be
recognized as a MAC address and does not need to be the MAC address
of the PC on which SoftClient is running.
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The MAC address field may even be left empty, in which case SoftClient
registers with the MAC address of the network interface through which it
is connecting. Note that this MAC address will change if the connection
is, for instance, moved between a WLAN and a cabled Ethernet
connection, and hence, this may not be the ideal solution.
As from AlphaPro version 11.0.3.0, the default setting for IP stations
(which includes SoftClient) is to register with the directory number as ID
by selecting Reg w/ Directory Number.
Deselecting Reg w/ Directory Number will allow the MAC address of
SoftClient to be entered. Earlier versions of AlphaPro do not have the
option of setting this parameter, in which case entering BBBBBBBBBBBB
as the MAC address will still enable the directory number of SoftClient to
be used as ID.

2.5

GUI Configuration

The GUI may be configured to suit operational needs. This can be done
by clicking File > Preferences.

When the PopUp on Incoming Call and PopUp on Call Requests
are both deselected, and SoftClient is minimized to the system tray, the
SoftClient can be used as an ‘audio only’ interface. This is ideal when
SoftClient resides on the same PC as a GUI for a management system
which takes care of call handling.
Selecting Window Always On Top ensures that communication
information is always visible and not lost because another application is
covering the SoftClient interface on the desktop.
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2.6

Importing/Exporting Contacts
2.6.1

Exporting Contacts from AlphaPro

A contact list may be exported from AlphaPro. This contact list contains
all directory numbers and names which are defined in the exchange with
Feature Number 9.
To export the contact list from AlphaPro, click the Reports icon, select
Users in the dialog-box and enter a name for the resulting file, which will
be stored in CSV format.

2.6.2

Importing Contacts to SoftClient

The contact list as generated above can be imported into the SoftClient,
by selecting Import AlphaPro Users under the Contacts menu.
The file as exported by AlphaPro does not provide additional fields for
entering the first and last name of a contact person, his/her location and a
group identifier. To add these fields to the contact list, do the following:
1. Click Export Contacts
2. Edit the resulting CSV format file in Excel
3. Click Import Contacts.
Entering information in the different fields will greatly enhance the
possibility of finding a contact quickly, especially in a large organization.

2.7

Audio Devices

It is highly recommended to use an audio device which suppresses
acoustic echo. This can either be a headset or a special unit with acoustic
echo cancellation, such as an internal audio card which supports this
feature or an external audio unit.
The performance of audio devices can be optimized by clicking File >
Preferences and then Configure Audio Device in the dialog-box. You
then have the option of selecting audio device and network type, and
testing audio playback and recording.
Selecting the checkbox for Enable DeNoising will filter out environmental
noise. On a laptop PC where the internal microphone is used, this feature
will filter out the noise caused by hard disk activity and the fan.
Selecting the checkbox for Enable Automatic Gain Control will increase
the microphone signal gain if the speech signal is too low, and will
decrease the gain when the signal is too high. This feature should be
enabled especially when the user is moving with respect to the location of
the microphone.
During the commissioning phase, it is possible to check the effect of
these settings during a conversation by clicking Actions > Toggle Audio
Processor On/Off.
At the start of the conversation, the values are always as set in the
Preferences dialog-box, but during the conversation it is possible to
toggle all the selected settings Off or On. In this way, the effect and
necessity of the settings may be evaluated. Note that some audio cards
or external audio devices also have these options built-in and that
running the same audio operation twice may have an adverse effect on
audio quality.
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A

Intercom User Quick Reference
Functions
Make a call
High background noise level
End a call
Re-dial
All Call
Group Call
Answer All Call / Group Call
Paging
Answer Paging
Radio Programs
Connect to telephone
Call Forwarding
Follow Me
Reset Call Forward / Follow Me remotely
Play back messages / Delete absence message
Wake-up / reminder within 24 hours
Wake-up / reminder after 24 hours
Call Request
Call Request transfer
Conference, Simplex
Conference, Duplex
Ringing Group
Alphabetical Name Search

Actions
Dial subscriber number
Press M when you speak
C
9532
84 + M to speak
85-89 + M to speak
99
Subscriber number + 44-47
96 or answer code shown in display
801-806 (off: C or 800)
0
71 + station number + M
72 + own number
73 + station number
70
7883 + hour + minute + M
7883 + hour + minute + day + month
623 + station number
7870
8201 - 8250 (Off: 8200) M to speak
8301 - 8320 (Off: 8300) C to leave
6701 - 6710
614

Number or key to press during conversation
Mute/Unmute microphone / Menu step 0
Paging with calling station number
Repeat absence message
1
Paging with answer
Inquiry Call & Broker Function
2
Text message paging
Call Transfer
3
Voice message paging
Door opening
6
Remotely change message
Leave voice/text message
7 + 66X
Remotely read message
Call Back
8
Busy Notify
Search
9
Busy Override
Private/Message Override
Absence messages
Out at the moment (until time: hhmm)
At a meeting (until time: hhmm)
Gone for the day (Back tomorrow at time: hhmm)
Absent today (until date: ddmm)
Busy at the moment (until time: hhmm)
At lunch (until time: hhmm)
On holiday (until date: ddmm)
Away for a few days (until date: ddmm)
Not available (Available on phone number: xxxx)

771
772
773
774
775
776
777
778
779

44
45
46
47
50
51
57 or M
58 or MM
59 or M

Standard voice and text messages
Contact the switchboard
660
Call phone number xxxxxxxx
661
Call home
663
Call your spouse
664
Call me
666
Remember meeting (at time: hhmm) 667
Fax waiting
668
Delivery waiting
669

"" The numbers on this page are factory default settings and may have been changed in your AlphaCom
exchange installation.
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